PartitionGuru - Ñïðàâêà

PartitionGuru - справка

 Top Next

Главное окно

Работа с разделами

1. Создание нового раздела

2. Активный раздел (Сделать раздел активным)

3. Удаление раздела

4. Форматирование раздела

5. Скрыть раздел

6. Изменение параметров раздела

7. Изменение размера раздела

8. Разделить раздел

9. Назначить или изменить букву диска

10. Резервное копирование раздела в файл

11. Восстановление раздела из файла

12. Открыть файл образа раздела

13. Копирование раздела (Клон раздела)

14. Восстановление удалённых или потерянных файлов(Восстановление файлов)

15. Восстановление файлов по типу

16. Быстро разделить раздел

17. Назначить имя тома

18. Преобразование типа раздела (основной или логический)

19. Удаление данных (перезапись секторов)

Операции с диском

1. Поиск потерянных разделов (восстановление разделов)

2. Восстановление главной загрузочной записи (Восстановление MBR)

3. Резервное копирование и восстановление таблицы разделов

4. Клонирование диска

5. Сделать загрузочный USB диск

6. Проверка и ремонт повреждённых секторов

7. Удалить все разделы

8. Очистить зарезервированные сектора

9. Преобразовать стиль таблицы разделов

10. Проверить и исправить ошибки таблицы разделов

Редактор секторов диска

1. Краткий обзор

2. Общие функции

3. Контекстное меню

Виртуальный диск и файлы образа

1. Создать файл виртуального диска VMware

2. Создать файл виртуального диска VirtualPC

3. Создать файл виртуального диска VirtualBox

4. Файл виртуального диска и его разделов

5. Создать образ диска или файл образа раздела

Операции с файламиe

1. Просмотр файлов

2. Копирование файлов из раздела

3. Запись файлов в раздел

4. Безвозвратное удаление файлов

5. Создать папку

Другие операции

Перезагрузка и запуск DOS версии PartitionGuru


Ãëàâíîå îêíî

Главное окно

 Top Previous Next

Главное окно PartitionGuru состоит из трех частей: "Структура разделов диска", "Разделы и дерево папок", "Параметры раздела и список файлов".

Структура разделов диска. Отображает структуру разделов диска. Показывает метку тома, размер раздела, букву диска и тип файловой системы. Типы файловой системы отображаются разным цветом. Логические разделы помечены точками. Текущий раздел окружен цветной рамкой. Щелчком мыши можно выбрать любой раздел в качестве текущего. В нижней части структуры раздела диска отображаются основные параметры текущего диска. Для переключения между жесткими дисками нажмите на значок стрелки в верхней левой части панели структуры разделов диска.

Разделы и дерево папок. Отображает список разделов всех дисков и дерево папок в разделах. Вы можете выбрать любые элементы дисков, разделов и папок с помощью мыши. Если щелкнуть на папку, то правая панель будет переключена на список всех файлов и подпапок в папке, на которую вы нажали.

Параметры раздела и список файлов. Отображает параметры детализации каждого раздела текущего жесткого диска, выбранного в верхней части окна, в структуре разделов диска.

Чтобы различать типы файловых систем каждого раздела, PartitionGuru использует различные цвета для различных типов файловых систем. Например, цвет для файловой системы FAT32 является синий, для NTFS коричневый и т.д. Разделы использует тот же цвет в каждой из трёх панелей.

Указанные три части главного окна взаимосвязаны. При нажатии на раздел (выбрать раздел) в одной части, остальные две части автоматически перейдут на выбранный раздел. При нажатии на папку (выбрать папку) в "Разделы и дерево папок ", "Параметры раздела и список файлов" (на правой стороне) будет изменен на список файлов и вложенных папок в текущей папке:

Будут перечислены все файлы в текущей выбранной папке, так же системные файлы, которые не отображаются в проводнике Windows. Файлы с различными атрибутами будут отображены разным цветом.

Вы можете вызвать всплывающее меню правой кнопкой мыши в каждой части главного окна.

4 | 5
6 |


Ðàáîòà ñ ðàçäåëàìè

Работа с разделами

PartitionGuru поддерживает следующие операции управления разделами:

1. Создание нового раздела

2. Активный раздел (Сделать раздел активным)

3. Удаление раздела

4. Форматирование раздела

5. Скрыть раздел

6. Изменение параметров раздела

7. Назначить или изменить букву диска

8. Резервное копирование раздела в файл

9. Восстановление раздела из файла

10.Открыть файл образа раздела

11. Копирование раздела (Клон раздела)

12. Восстановление удалённых или потерянных файлов

13. Быстро разделитьть раздел

14. Назначить имя тома

15. Преобразование типа раздела в Основной или Логический


1. Ñîçäàíèå íîâîãî ðàçäåëà

1. Создание нового раздела

Тип раздела должен быть определен до создания нового раздела. Существует три типа раздела: основной, расширенный и логический разделы.

Основной раздел - это раздел, созданный на жестком диске и используется для установки и загрузки операционной системы. В результате ограничения таблицы разделов, можно максимум создать четыре основных раздела (или три основных раздела и один расширенный) на одном жестком диске.

Расширенный раздел - это своего рода специальный первичный раздел, используемый для создания на нём логических разделов. Может быть создано несколько логических разделов в расширенном разделе.

Логический раздел-это раздел, созданный в расширенном разделе, количество логических разделов не имеет ограничений.

1.Создание нового раздела на свободном месте диска

Чтобы создать основной или расширенный раздел, выберите свободное пространство серого цвета на структуре разделов диска. Для создания логического раздела выберите свободное пространство окрашенное в зеленый цвет в расширенном разделе.

Затем нажмите "Создать" на панели инструментов или выберите пункт меню "Раздел" - "Создать новый раздел" или щелкнуть правой кнопкой мыши на свободном месте в параметрах раздела и выберите "Создать новый раздел" в всплывающем меню.

Появится диалоговое окно «Создание нового раздела», как показано ниже:

В соответствии с вашими потребностями выберите тип раздела и тип файловой системы, введите размер раздела и нажмите «ОК».

Жёсткие диски, которые имеют большие 4 КБ сектора, такие как Western Digital's Advanced Format, должны быть приведены в соответствие кратного количество физических секторов, в противном случае, его производительность и эффективность будут снижены. В этом случае вы должны проверить параметр «Выравнивать по составным секторам» и выбрать количество секторов для выравнивания.

Если вы хотите задать дополнительные параметры, можете нажать «Дополнительно», чтобы открыть следующее диалоговое окно:

Для таблицы разделов GUID можно задать дополнительные свойства нового раздела. После того, ка настройка будет готова нажмите «ОК» и будет создан новый раздел, в соответствии с заданными параметрами.

Вновь созданный раздел не сохраняется сразу на жёсткий диск, он хранится в памяти. Только после сохранения таблицы разделов вы можете увидеть раздел в «Мой компьютер». Цель этого заключается в том, чтобы предотвратить уничтожение данных. Нажав в меню "Диск" - "Сохранить таблицу разделов", вы сохраняете таблицу разделов.

Чтобы использовать новый раздел, вам нужно форматировать его, после сохранения таблицы разделов.

2.Создание нового раздела из существующего раздела

Иногда нужно создать новый раздел из существующего раздела, вы можете легко сделать это с PartitionGuru.

Выберите раздел которой вы хотите изменить, щелкните правой кнопкой мыши, выберите команду в меню "Создать новый раздел", как показано на рисунке ниже:

Появится диалоговое окно «Изменение размера раздела», вы можете настроить параметры нового раздела, такие как: размер, позиции..., то есть, такие же операции , как Изменение размер раздела без потерь:


2. Àêòèâíûé ðàçäåë

2. Активный раздел

Активный раздел является основным разделом и используется для загрузки операционной системы. Жесткий диск может иметь только один активный раздел.

Чтобы пометить текущий раздел как активный, нажмите на кнопку «Активный» на панели инструментов или выберите пункт меню «Раздел» «Отметить раздел как активный», или щелкните правой кнопкой мыши на раздел, он должен быть активирован и в всплывающем меню выберите пункт «Отметить раздел как активный». Если один активный раздел уже существует, то пункт «Отметить раздел как активный» будет неактивен.

Активную метку текущего раздела можно удалить, нажав пункт меню «Раздел»--> «Удалить раздел отмеченный как активный», что делает неактивным раздел на диске.


3. Óäàëåíèå ðàçäåëà

3. Удаление раздела

Выберите раздел для удаления, затем нажмите "Удалить" на панели инструментов или нажмите пункт меню "Раздел" и "Удалить текущий раздел" или щелкнуть правой кнопкой мыши на раздел, в всплывающем меню выберите пункт "Удалить текущий раздел". PartitionGuru покажет следующее предупреждение:

Нажмите кнопку «Да» и текущий раздел будет удален.

Изменения не будут сохранены на жесткий диск сразу, чтобы избежать потери данных вызванные неправильным действием, оно сохранится в памяти, прежде чем вы выполните команду «Сохранить таблицу разделов».


4. Ôîðìàòèðîâàíèå ðàçäåëà

4. Форматирование раздела

Вновь созданный раздел не может использоваться для сохранения файлов, необходимо его отформатировать. PartitionGuru поддерживает форматирование NTFS, FAT32, FAT12, FAT16, и т.д.

Выберите текущий раздел, который должен быть отформатирован, затем нажмите кнопку «Формат» на панели инструментов или в меню «Раздел» «Форматировать текущий раздел» или щелкните правой кнопкой мыши на раздел и в всплывающем меню выберите «Форматировать текущий раздел». В PartitionGuru появится диалоговое окно:

После выбора файловой системы, "Размер кластера" и установив метку тома, вы можете нажать "Форматировать", чтобы подготовить операцию для форматирования .

Вы можете сканировать на поврежденные сектора при форматировании (Проверка поверхности), но необходимо отметить, что сканирование поврежденных секторов является длительным процессом. На самом деле жестким дискам, особенно новым, не требуется сканирования. Если плохие сектора будут найдены в процессе сканирования, PartitionGuru пометит их и они не будут использоваться для сохранения данных.

Для файловой системы NTFS, можете отметить «Сжимать», для включения атрибута сжатия NTFS.

Если это основной раздел и файловая система выбрана FAT32/FAT16/FAT12, флажок «Создать DOS систему» станет активен. Убедитесь, что DOS система будет создана в этот раздел после форматирования, который может использоваться для запуска компьютера в системе DOS.

Чтобы избежать неправильной или нежелаемой операцией, PartitionGuru покажет следующее окно предупреждение:

Нажмите «Да» и начнется операция форматирования. Будет показан ход выполнения форматирования.

Если вы выбрали «Создание DOS системы», PartitionGuru будет копировать файлы системы DOS в раздел после завершения форматирования.


5. Ñêðûòü ðàçäåë

5. Скрыть раздел

1. Скрыть раздел

Если раздел скрыт, ему не будет назначена буква диска операционной системой и его не видно в "Мой компьютер". Приложение недоступно к скрытому разделу, но файлы в скрытом разделе не потеряны, они просто недоступны в обычном режиме.

Чтобы скрыть текущий раздел, нажмите в меню "Раздел" и "Скрыть текущий раздел", или щелкните правой кнопкой мыши на раздел и выберите пункт "Скрыть текущий раздел" в всплывающем меню. Если текущий раздел является системным, PartitionGuru покажет следующее сообщение:

Если PartitionGuru установлен на текущем разделе, будет показано следующее сообщение:

В противном случае, PartitionGuru попытается заблокировать раздел. Если раздел используется, PartitionGuru спросит, хотите ли отключить текущий раздел:

Если раздел блокирован успешно, PartitionGuru удалит букву текущего раздела и скроет его. Раздел будет невидим в "Мой компьютер", но его файлы будут доступны в PartitionGuru.

2. Показать раздел

Чтобы показать раздел, выберите скрытый раздел, нажмите пункт меню "Раздел" и "Показать текущий раздел". PartitionGuru удалит его скрытое состояния.

Для предотвращения потери данных, из-за неправильных действий, изменения не будут сохранены на жёсткий диск, они только будут сохранены в памяти до тех пор, пока вы не выполните команду «Сохранить таблицу разделов».


6. Èçìåíåíèå ïàðàìåòðîâ ðàçäåëà

6. Изменение параметров раздела

Эта функция поможет вам изменить детальные параметры созданного раздела.

Нажмите пункт меню "Раздел" "Изменить параметры раздела" или щелкните правой кнопкой мыши на раздел, на котором необходимо изменить параметры и в всплывающем меню выберите "Изменить параметры раздела". Появится диалоговое окно:

Здесь можно настроить положение начала и конца раздела, а также идентификатор системы.

Необходимо отметить, изменение идентификатора системы не означает изменение типа раздела и типа файловой системы. Так же изменение размера раздела не означает изменение без потерь, относительно отформатированного раздела, неправильная регулировка может привести к тому, что файлы станут недоступными!

Для предотвращения потери данных, из-за неправильных действий изменения не будут немедленно сохранены на жёсткий диск, они будут сохранены в памяти до тех пор, пока вы не выполните команду «Сохранить таблицу разделов».


7. Èçìåíåíèå ðàçìåðà ðàçäåëà

7. Изменение размера раздела

Изменение размера разделов без потери данных является очень важной и практичной функцией управления разделами диска. Вы можете изменить размер раздела без потери данных, быстро и удобно с помощью PartitionGuru.

Чтобы изменить размер раздела, выберите раздел, который требует изменения размера, затем щелкните правой кнопкой мыши и выберите «Изменить размер раздела» в всплывающем меню, как показано ниже:

Изменение размера раздела обычно затрагивает два раздела. Например, чтобы расширить раздел, необходимо сжать еще один раздел, или наоборот.

Вопрос? Изменяя размер раздела, какой раздел следует выбрать первым?

Ответ - тот, который будет уменьшаться. В следующей части рассмотрим пример, как изменить размер разделов при помощи PartitionGuru.

Картина выше показывает разделы съемного диска. Предположим, мы хотим уменьшить средний раздел на 0.6 гиг, и там освободится 0.6 гиг свободного пространства. Мы распределим его на соседние разделы по 0.3 гиг.

Далее показаны подробные шаги по изменению размера разделов без потери данных.

1. Выберем средний раздел, кликнем правой кнопкой мыши и выбераем пункт меню "Изменить размер раздела":

2. Зададим параметры настройки в всплывающем диалоговом окне «Изменить размер раздела», как показано ниже:

а). вводим 0.3ГБ в "Место перед данными", затем нажимаем "Начать" и входим в "Изменить размер раздела", как описано в пункте 1. Диалог изменился следующим образом:

б. Обычно не должно быть свободного дискового пространства. Щелкнем на раскрывающейся список и выберем «Слияние Съёмный диск(J:) ", как показано ниже:

c. Размер "Место после данных" изменяем таким же образом. Изменим размер 0.3 ГБ и выбираем «Слияние Логический диск (6:) ", как показано в следующем рисунке:

3. Нажмите «Начать» и в всплывающем окне будут показаны последовательные шаги и вопросы, которые необходимо выполнить:

4. Нажмите кнопку «Да» и PartitionGuru начнет изменения размеров разделов без потери данных. В процессе выполнения PartitionGu покажет информацию о текущих операциях в деталях, как показано ниже:

5.Когда PartitionGuru закончит,изменение размера раздела, нажимаем «Начать», закроется диалоговое окно «Изменение размер раздела»:

6. Будут видны разделы, которые были изменены успешно! Как показано ниже:

При использовании PartitionGuru для изменения размера раздела без потерь, вы должны обратить внимание на следующее:

1.Если операция включает в себя системный раздел (обычно C:), PartitionGuru автоматически перезагрузит компьютер и войдёт в режим DOS. Он запустит DOS-версию для завершения изменения размера раздела, компьютер будет автоматически перезагружен после завершения изменения размера раздела в систему Windows.

2.PartitionGuru поддерживает операции мыши, для изменения размера раздела, т.е. с помощью мыши можно изменить размер раздела, перемещая границу раздела. Так же можно назначить размер раздела изменением секторов и т.д., как показано ниже:

3.Во время процесса изменения размера раздела необходимо закрыть все программы. Иначе PartitionGuru будет фиксировать эти изменения ( место до и после данных) и размер раздела будет изменен автоматически.

4.Если раздел велик и слишком много данных , изменение размера разделов без потери займет некоторое время, вы можете назначить операцию после завершения процесса.

5.Вполне возможно, что диск, таблица и файловая система разделов имеют ошибки, тогда изменение размеров разделов без потери данных является своего рода рискованной операцией. Если есть ошибки, упомянутые выше, корректировка может быть неудачной, или еще хуже, это может привести к потере данных. Поэтому если у вас есть важные файлы, сделайте их резервные копии до начала всех операций!

PartitionGuru будет напоминать вам это, перед изменением размера раздела, как показано ниже:


8. Ðàçäåëèòü ðàçäåë

8. Разделить раздел

Иногда необходимо разделить один раздел на несколько. Это легко осуществить с помощью PartitionGuru, в разделе Изменение размера раздела без потерь на свободном пространстве, просто выберите опцию «Создание нового раздела»:

Более того, в ParttionGuru есть удобная функция "Создать новый раздел". Выберите раздел, который должен быть разбит и щелкните правой кнопкой мыши, затем в всплывающем меню выберите пункт "Создать новый раздел" как показано ниже:

Затем PartitionGuru отобразит диалоговое окно «Изменение размера раздела». Для удобства пользователей новый раздел заранее построен в задней части раздела с половины размера свободного пространства, как показано на следующей картинке.

В соответствии с потребностями, пользователи могут изменять параметры раздела, в диалоговом окне Изменение размера раздела, то есть аналогично операции описанной в Изменение размера раздела.


9. Íàçíà÷èòü èëè èçìåíèòü áóêâó äèñêà

9. Назначить или изменить букву диска

1.Назначить или изменить букву раздела диска

Выберите раздел, которому нужно назначить букву диска, нажмите в меню «Раздел» «Назначить букву диска», или щелкните правой кнопкой мыши на раздел и в всплывающем меню выберите «Назначить букву диска». PartitionGuru покажет диалоговое окно:

Нажмите кнопку «ОК», после того, как вы выберите новую букву диска и раздел будет назначена буква диска. Оригинал будет удален.

2. Удалить букву диска

Выберите раздел, на котором необходимо удалить букву диска, затем нажмите в меню «Раздел» «Удалить букву диска», или щелкните правой кнопкой мыши на раздел и выберите пункт «Удалить букву диска» в всплывающем меню. Если раздел используется PartitionGuru, то он покажет следующее предупреждающее сообщение:

Нажмите кнопку "Да" и буква диска будут удалена.


10. Ðåçåðâíîå êîïèðîâàíèå ðàçäåëà â ôàéë

10. Резервное копирование раздела в файл

Функция означает, резервное копирование всех имеющихся данных раздела в назначенный файл (файл образа), таким образом раздел может быть восстановлен из файла образа, когда он будет повреждён. PartitionGuru обеспечивает три режима резервного копирования.

1.Резервное копирование всех секторов

Резервное копирование всех секторов исходного раздела (или объема) в файл образа от начала до конца, даже если раздел имеет повреждённые данные.Это будет копирование всех имеющихся данных, но и также много бесполезных файлов, которые совершенно не нужны. Скорость низкая, так как выполняется резервное копирование слишком большого количества данных. PartitionGuru может восстановить данные только на исходный раздел или раздел с тем же размером, что и источник.

2.Резервное копирование раздела структуры хранения

Копирует только действительные данные исходного раздела структуры файловой системы в файл образа, без каких либо изменений. PartitionGuru копирует только задействованные сектора. Этот путь является самым быстрым. Но при восстанавлении данных, как и в первом способе, требует, чтобы целевой раздел и раздел источник были одного размера.

3.Резервное копирование в файл

Резервное копирование всех файлов и другиех данных исходного раздела в файл образа, упаковывая их по одному. Этот режим не копирует поврежденные данные, процесс очень быстрый. При восстановлении PartitionGuru может восстановить резервные данные раздела (или объем), на разделы, размер которых может отличаться от оригинала, но не должен быть меньше, чем размер исходного раздела. Этот режим очень гибкий. При восстановлении файлов, их расположение для хранения будет реорганизовано. В общем, восстановленный раздел не будет иметь фрагментированных файлов.

Чтобы уменьшить размер файл образа, вы можете выбрать режим сжатия файлов при копировании данных, который может повлиять на скорость резервного копирования. Если вы выбираете более высокое сжатие данных, тем медленнее скорость резервного копирования и меньше размер файла образа. Рекомендуется выбрать режим «Быстрое».

Чтобы начать резервное копирование, нажмите на «Бэкап» на панели инструментов, или выберите в меню «Инструменты» и «Клонировать раздел в файл образа», PartitionGuru покажет следующее диалоговое окно:

Нажмите кнопку "Исходный раздел", чтобы выбрать раздел для резервного копирования, в PartitionGuru появится следующее диалоговое окно:

Выберите раздел для резервного копирования и нажмите кнопку «ОК». Затем выберите путь к файлу, параметры резервного копирования и режим сжатия, введите комментарий (не более 240байт), нажмите кнопку «Пуск». PartitionGuru покажет предупреждение:

Нажмите кнопку «ОК», PartitionGuru попытается заблокировать раздел, который нуждается в резервном копировании. Если он не сможет заблокировать раздел, он покажет следующее сообщение:

Если раздел будет заблокирован, то начнется процесс резервного копирования, как показано ниже:


11. Âîññòàíîâëåíèå ðàçäåëà èç ôàéëà

11. Восстановление раздела из файла

Когда раздел поврежден, он может быть восстановлен в первоначальное состояние из сделанной ранее резервной копии файла образа. В меню нажмите «Инструменты» «Восстановить раздел из файла образа», В PartitionGuru появится следующее диалоговое окно:

Нажмите на кнопку «Файл образа» выберите файл образа (.pmf). Затем нажмите кнопку «Раздел назначения » и выберите раздел для восстановления. Поле диалогового окна будет отображать сведения о файле образа. Если файл образа и целевой раздел выбраны правильно, нажмите кнопку «Старт» для подготовки восстановления раздела. PartitionGuru покажет предупреждающее сообщение:

Нажмите "OK", если вы уверены, что нет ошибок и PartitionGuru начнет восстановление раздела:

Если файл образа резервной копии и исходный раздел не заблокирован в процессе резервного копирования, PartitionGuru автоматически проанализирует и исправит восстановленные данные после завершения восстановления раздела.


12. Îòêðûòü ôàéë îáðàçà ðàçäåëà

12. Открыть файл образа раздела

С помощью PartitionGuru, можно загрузить и открыть образ раздела и извлекать файлы из образа. Образ будет отображаться как раздел.

Чтобы загрузить файл образа, выберите в меню "Инструменты" -> "Изучить образ раздела". Будет показано диалоговое окно:

Выберите файл образа раздела, который вы хотите открыть, а затем нажмите кнопку "Открыть". Откроется диалоговое окно показанное ниже. Если всё выбрано правильно нажмите "Пуск" и PartitionGuru начнет загрузку образа:

После того, как образ будет загружен в качестве раздела, вы можете использовать его как раздел только для чтения.

Например можно посмотреть свои файлы или копировать файлы на другой раздел.


13. Êîïèðîâàíèå ðàçäåëà (Êëîí ðàçäåëà)

13. Копирование раздела (Клон раздела)

 Top Previous Next

Копирование раздела - это копирование данных с одного раздела на другой. PrtititonGuru обеспечивает три режима резервного копирования раздела:

1.Копирования всех секторов.

Копирование всех секторов исходного раздела (или объема) от начала до конца, даже если раздел имеет повреждённые сектора.Это будет копирование действительно всех имеющихся данных, которые содержат много бесполезных. Скорость низкая, так как выполняется резервное копирование слишком большого количества данных. Но это самый полный метод копирования, который может скопировать все данные исходного раздела в целевой раздел. Этот способ не перестраивает данные, поэтому размер целевого раздела и исходного должен быть одинаковым.

2.Копирование всех секторов в соответствии с расположением файловой системы.

Копирует только действительные данные исходного раздела структуры файловой системы, без какого либо изменения. PartitionGuru будет избавляться от повреждённых секторов при копировании данных. Этот режим является самым быстрым. Но при восстанавлении данных, как и в первом способе, этот способ тоже не перестраивает данные и он требует, чтобы целевой раздел и исходный были одинакового размера.

3.Копирование всех файлов.

Копирует все данные из исходного раздела в целевой раздел (или объем) с анализом структуры файловой системы. При копировании данных, PartitionGuru перенесёт файлы из целевого раздела в соответствии со структурой файловой системы. Там не будет фрагментированных файлов, это довольно быстрй процесс. Этот метод не требует, чтобы размер целевого раздел был таким же, как исходный, но размер целевого раздела должен быть больше, чем размер исходного раздела.

Чтобы скопировать данные, выберите пункты меню «Инструменты» «Клонировать раздел», или щелкните правой кнопкой мыши на раздел и выберите «Клонировать раздел». В PartitionGuru появится диалоговое окно:

Нажмите на кнопку "Исходный раздел", Partitionguru покажет диалоговое окно, как показано ниже:

После выбора исходного и целевого раздела, в диалоговом окне "Копирования раздела" выберите подходящий режим копирования в соответствии с вашим требованием. Если размер целевого раздела отличается от исходного раздела, можно выбрать только 3-й режим "Скопировать все файлы". Нажмите "Начать", PartitionGuru покажет предупреждающее сообщение:

Нажмите кнопку "ОК", если нет ошибок PartitiomGuru заблокирует раздел, если он не сможет заблокировать исходный раздел (обычно системный и раздел, на котором устанавлен PartitionGuru), PartitionGuru покажет предупреждение:

Если исходный раздел больше целевого раздела то после нажатия "ОК" PartitionGuru покажет следующее сообщение:


14. Âîññòàíîâëåíèå ôàéëîâ

14. Восстановление файлов

Если вы хотите восстановить файлы, которые были удалены случайно или намеренно, так же были повреждены вирусом или раздел был отформатирован, вы можете использовать эту функцию для восстановления данных. На самом деле, когда операционная система удаляет файл, она просто помечает этот файл как "удаленный", помечая дисковое пространство занимаемое файлом, как "свободное". Данные не удаляются и остаются на диске. Можно восстановить эти удаленные файлы, если на этом месте не были созданы файлы или записаны новые данные.

Операция форматирования не затрагивает содержимое исходных данных и не удаляет старые файлы. Конкретные операции форматирования варьируется в зависимости от типа файловой системы. Для типов файловой системы FAT32, FAT16 и FAT12 форматирование очистит таблицу размещения файлов (в FAT это фиксируется в начале раздела и содержит информацию распределения данных) и корневой каталог. Данные не будут удалены. Для файловой системы NTFS после форматирования, новые записанные данные не имеют фиксированного положения, но, как правило, позиция записи после форматирования не меняется. Таким образом, наиболее поздние файлы не будут перезаписаны и большое количество оставшейся информации может помочь восстановить потерянные файлы.

Эта функция используется для поиска файлов и их иерархической структуры, анализируя данные оставшиеся на диске, так, что бы файлы могли быть восстановлены.

Если теряется весь раздел, обратитесь к функции «Поиск потерянных разделов (восстановление разделов)» и если он будет найден, вы можете восстановить файлы с этого раздела, независимо от того, сохранена таблица раздела или нет.

Раздел поврежден, если в "Мой компьютер" он отображается как «Неформатированный» или «Нуждается в форматировании». Его свойства файловой системы показывает «RAW», файлы раздела не видны. Эта функция используеться в таких ситуациях для восстановления данных.

Функция поддерживает NTFS, FAT12, FAT16, FAT32 и т. д. Также поддерживает тома RAID, USB флэш-диск и карт памяти (например, SD-карты и карты XD камер), которые используют эти типы файловых систем.

Чтобы предотвратить раздел от вторичного повреждения при восстановлении данных при поиске файлов, PartitionGuru применяет режим только для чтения, так что, никакие данные не могут быть записаны в раздел.

Чтобы восстановить файлы, выберите раздел, где были удаленны файлы, затем нажмите «Файл» на панели инструментов, или нажмите «Инструменты» в главное меню и выберите «Восстановить потерянные файлы», появится диалоговое окно:

Так как процесс восстановления данных удаленных файлов и форматированных файлов отличается, мы объясним эти два процесса отдельно. Вот подробные шаги:

I. Восстановление удаленных файлов:

Выберите "Восстановление удаленных файлов" в диалоговом окне "Восстановление файлов".

Если новые данные записываются в раздел после удаления, вам лучше проверить опцией «Поиск файлов известных типов» и нажмите «Выберите типы файлов», чтобы установить типы файлов. После выбора этого варианта, PartitionGuru будет сканировать все пространство. Если он находит тип требуемого файла, он отобразит эти файлы в папке «Все типы». Если удаленный файл не удается найти, он может найден в папке «Другие» по расширению файла.

Во многих случаях, файлы не могут быть восстановлены с помощью функций восстановления, даже если они были удалены недавно, потому что важная информация файлов была разрушена операционной системой или неправильными действиями пользователя. И эти вторичные разрушения, вызванные неправильной операцией обычно происходит, например, когда вы случайно удаляете фотографию, открываете Проводник Windows и сразу начинаете искать удаленный файл в каждом каталоге, при этом используете функцию предварительного просмотра эскизов. Эти операция уничтожает много важной информации удаленных файлов. Для предварительного просмотра эскизов генерируются файлы кэша. Аналогичных непреднамеренных операций слишком много. В этой ситуации, вы должны использовать метод «сканирования файла по типу» для восстановления данных. Хотя этим методом найденные файлы маркируютя номером, вы все равно можете найти их, предварительно просмотрев или открыв после копирования, что особенно эффективно для восстановления фотографий и документов Office.

Так как это займет немного больше времени, чтобы «Сканировать файлы по типу» (он сканирует все пространство), предлагается попробовать первый обычный метод. Если вам не удается найти файлы, которые вы хотите восстановить, то вы можете выбрать этот режим.

Если выполняется поиск в FAT32, вы также можете попробовать опцию «Восстанавливать удаленные файлы». Из-за особенности, которая система FAT 32 удаляет файлы, некоторые удаленные файлы не могут быть найдены, если вы не сканируете раздел целиком. Восстановление удаленных файлов занимает больше времени, поэтому рекомендуется сканирование раздела полностью.

Нажмите кнопку "Пуск", чтобы начать сканирование:

После сканирования закроется диалоговое окно «Восстановление файлов». PartitionGuru отобразит файлы, которые он находит в главном интерфейсе. Каждый удаленный файл имеет метку на его левой стороне и так же есть метки на элементах дерева папок:

Те файлы и папки, которые не могут быть идентифицированы, PartitionGuru объединяет их в папку под названием "Потерянные файлы". Если вы не можете найти удаленные файлы по их исходному положению, вы можете попробовать найти их в этой папке. Пожалуйста, не забывайте эту папку при восстановлении данных, и вполне возможно, что ваши важные данные в этой папке.

В процессе восстановления файлов, «Атрибут» удаленных файлов в списке файлов будут добавлены два дополнительных знака «D» и «X». D представляет собой файл, который удаленн и X означает, что файл был перезаписан частично или полностью и он не может быть восстановлен полностью.

Для облегчения пользователям идентифицировать файлы, PartitionGuru может отображать обычные файлы. Обычные файлы не имеют метку и они не могут быть выбраны для восстановления.

Чтобы восстановить файлы, выберите файлы с меткой, затем щелкните правой кнопкой мыши или нажмите кнопку "Файл", "Копировать". Выберите папку для сохранения восстановленных файлов и нажмите "ОК". PartitionGuru будет копировать выбранные файлы в назначенную папку. Для предотвращения вторичного разрушения данных, при их восстановления, файлы не могут быть скопированы в исходный раздел.

Нажмите кнопку «Завершить» и закройтеь диалоговое окно Копирование файла и PartitionGuru автоматически очистит выбранное состояние файлов, далее можно выбрать другие файлы.

Когда все данные будут скопированы, вы можете нажать кнопку "Раздел" "Перезагрузить текущий раздел", чтобы освободить кэш данных текущего раздела из памяти и загрузить текущий раздел с диска, чтобы показать состояние текущего раздела.

II. Восстановить все файлы раздела (восстановить отформатированные файлы)

Выберите "Восстановить все файлы раздела" в диалоговом окне "Восстановление файлов". Между тем опция "Поиск файлов известных типов" должна быть проверена, нажмите кнопку "Выберите типы файлов", чтобы задать типы файлов, которые нуждаются в восстановлении. Установите нужные флажки, PartitionGuru будет сканировать раздел, а также восстановит файлы по типам, в соответствии с заголовком назначенных типов файлов. После завершения восстановления, PartitionGuru разделит каталог по расширению файлов и перенесёт все найденные файлы из виртуального раздела. Этот метод немного медленный, но это не влияет на нормальное восстановление и он может восстановить несколько файлов.

Нажмите кнопку "Пуск", чтобы начать процесс сканирования. Этот метод поиска занимает больше времени. И следующие действия такие же, как и "Восстановить удаленные файлы". Пожалуйста, обратитесь к методике, приведенной в первой части.


15. Âîññòàíîâëåíèå ôàéëîâ ïî òèïó

15. Восстановление файлов по типу

Иногда данные повреждены так сильно, что обычный режим восстановления не удовлетворяет результату поиска. PartitionGuru обеспечивает лучший способ восстановления данных, то есть восстановление файлов по типу.

Эта функция является достаточно мощной. Она поддерживает более 100 типов файлов, так что результат восстановления велик, кроме того, это очень удобно в использовании.

В PartitionGuru есть два способа восстановления файлов по типу. В режиме восстановления удаленных файлов или отформатированных файлов, PartitionGuru предоставляет дополнительную функцию поиск файлов по типу и отображает список файлов в результате сканирования, кроме того, PartitionGuru обеспечивает режим восстановления файлов по типу, который выводит непосредственно список. Этот режим, по сравнению с первым, является гораздо более гибким. Например, он может искать по всему пространству диска и назначить позицию выравнивания данных.

Чтобы восстановить файлы по типу, выберите раздел, на котором вы хотите восстановить файлы, а затем выберите "Инструменты" и "Восстановить файлы по типу" в главном меню.

В диалоговом окне всплывающего окна, вы можете установить некоторые параметры режиме восстановления, например, вы можете выбрать "Только свободные кластеры", "Все секторы" и т.д.

Нажмите кнопку "Выбрать Типы файлов", чтобы установить определенный тип файла; PartitionGuru по умолчанию омтечает все типы файлов, вы можете выбрать несколько видов из них.

Закончив поиск, файлы будут отсортированы по типу, и каждый тип имеет одну или несколько папок с именем, по типу файлов. Каждая папка может содержать более 1000 файлов.

Файлы, найденные этим методом, будут без имени, PartitionGuru именам этих файлов присвоит номера. Если вы хотите посмотреть, являются ли они файлами, которые нужно восстановить, можно судить по размеру или после предварительного просмотра.


16. Áûñòðî ðàçäåëèòü ðàçäåë

16. Быстро разделить раздел

Эта функция используется для быстрой разметки жесткого диска, для секционирования нового жесткого диска или полностью разбитого жесткого диска, который уже секционирован. PatitionGuru удалит все существующие разделы и разметит жесткий диск в соответствии с требованиями, затем он отформатирует все разделы. Пользователь может задать размер раздела, тип, метка тома, и др. Всего несколько шагов достаточно, чтобы разбить и отформатировать диск. Если вы не измените дефолтные настройки, размер раздела, тип, метка тома и т. д, вы можете нажать кнопку "OK" (или клавиша F6) и закончить перераспределение.

Чтобы начать быстрое создание разделов, выберите жесткий диск, затем нажмите "Быстро" или нажмите клавишу F6, PartitionGuru покажет следующее диалоговое окно:

По умолчанию PartitionGuru принимает текущий жесткий диск в качестве целевого, для разделения. Если текущий диск не тот, который вы хотите разделить, нажмите на имя диска в окне в верхней левой части и в PartitionGuru появится всплывающее диалоговое окно для выбора диска.

1.Укажите количество разделов:

Вы можете нажать "3, 4, 5 или 6", чтобы выбрать количество разделов, или просто нажмите "Задать", чтобы выбрать количество разделов. В правой части диалогового окна отображается список разделов. Количество разделов по умолчанию определяется емкостью диска, как показано ниже:

Размер диска | Количество разделов по умолчанию
less than 60GB | 3 partitions
60GB - 150GB | 4 partitions
150GB - 320GB | 5 partitions
320GB + | 6 partitions

2.Изменить параметры раздела:

Правая половина диалоговом окна показывает тип, размер, метка тома раздела и является ли раздел первичным разделом. Пользователи могут изменять эти параметры, в соответствии со своими потребностями.

a.Тип раздела:

Быстрое разделение предоставляет только два типа: NTFS и FAT32.

b.Размер раздела:

Размер разделов по умолчанию распределяется по следующим правилам: во-первых, согласно числу разделов, если каждый раздел меньше, чем 15 ГБ, PartitionGuru разделит диск поровну. Во-вторых, если средний размер каждого раздела составляет не менее чем 15 ГБ, то первому разделу назначаетсят 1/20 от общего размера. 25 ГБ - минимальный размер и если расчетный размер будет меньшим, чем 25 ГБ тогда, первый раздел будет фиксирован как 25 ГБ. Другие разделы делят остальное пространство поровну. Этот раздел обычно используется, чтобы установить операционную систему и программное обеспечение. Вы можете скорректировать первый раздел, исходя из того, какую операционную систему и сколько программ вы будете ставить.

Есть иконка похожая на "замок" в левой части поля ввода размера раздела. Когда пользователь изменяет размер одного раздела, то этот раздел с замком будет "заблокирован", его размер не будет изменятся автоматически, когда другие разделы корректируются. Пользователь может изменить состояние "замок", нажав на значок, при инициализации или когда размер раздела изменяется, первый раздел заблокирован, то другие разделы будут разблокированы. Если размер одного раздела изменен, другие разделы будут разделять свободное пространство автоматически и если все разделы заблокированы, кроме изменяемого раздела, PartitionGuru будет изменять первый и последних размер разделов. Если окончательно скорректированн первый раздел, PartitionGuru будет автоматически регулировать последний раздел, и наоборот. Разделы, которые были скорректированы будут разблокированы автоматически.

Нажмите кнопку "По умолчанию" и PartitionGuru сбросит введённые размеры разделов "согласно с правилами" по умолчанию.

Разделы, созданные этой функции являются «Составнымй размером раздела» за исключением одного раздела, который использует оставшееся пространство диска.

c. Метка тома

PartitionGuru назначает метку по умолчанию для каждого раздела, но пользователи могут изменять или выбирать одну из них. Также пользователь может нажать кнопку "Снять все метки", для удаления всех меток.

d. Основной раздел или нет (этот параметр является недопустимым для таблицы разделов GUID)

Позволяет выбрать один раздел в качестве основного или логического раздела. Следует отметить, что если существует более 4 первичных разделов, дополнительные разделы должны быть назначены в качестве логических разделов. Расширенный раздел - это первичный раздел. PartitiomGuru будет автоматически следить, может ли эта опция включена или нет.

e. Выравнивание разделов

Некоторые современные жесткие диски, такие как Western Digital Advanced Format с физическими секторами размером 4 КБ следует выровнять к кратному числу секторов, для того, чтобы обеспечить максимальную производительность. Таким образом, вы должны проверить "Выравнивает разделы кратно числу секторов" и выбрать необходимое число для выравнивания.

3. Другие настройки:

a. Перестроить основную загрузочную запись (MBR)

Это опция стоит по умолчанию. Если есть MBR, на основе менеджера загрузки программы установки на диске, и она должна быть сохранена для дальнейшего использования, не включайте эту опцию.

b. GPT Диск:

Эта функция применяется к построению таблицы GUID разделов на GPT-диске. На правой верхней части диалогового окна есть флажок «Дополнительные параметры», показывает стиль таблицы разделов («MBR» или «GUID») текущего диска.

В дополнение к GPT-диск, можно также выбрать вариант раздела ESP и MSR. Если ESP уже существует, вы можете выбрать «Сохранить существующий раздел ESP» или «Создать новый раздел ESP».

После того, как все настройки сделаны, нажмите кнопку "OK", чтобы начать создание разделов и форматирование. Если есть старые разделы диска, PartitionGuru покажет следующее окно сообщения:

PartitionGuru выполнит быстрое разделение, все оригинальные разделы, если они есть, будут удалены автоматически. Основной раздел, сделанный в первую очередь, будет активирован автоматически.


17. Íàçíà÷èòü èìÿ òîìà

17. Назначить имя тома

В PartitionGuru можно задать и изменить имена томов.

Сначала выберите раздел, на котором необходимо изменить имя тома, затем выберите пункт меню «Раздел» и «Задать имя тома», или щелкните правой кнопкой мыши на раздел и в всплывающем меню выберите «Задать имя тома». PartitionGuru покажет диалоговое окно:

Введите метку тома, который требуется установить или изменить, затем нажмите кнопку "OK".

Для FAT32, помимо обычных меток, можно задать BPB (DBR), метки сохраняются в DOS загрузочную запись.


18. Ïðåîáðàçîâàíèå òèïà ðàçäåëà

18. Преобразование типа раздела

В некоторых случаях эта функция может осуществить преобразование между основным и логическим разделами. Из-за ограничения таблицы MBR, не более четырех первичных разделов (включая один расширенный раздел, если таковые имеются) на одном диске, преобразование типа раздела между первичным и логическим имеет некоторые ограничения:

Основной в логический

Чтобы преобразовать основной раздел в логический, должны быть соблюдены следующие требования:

1. Перед основной разделом должны быть свободные сектора, которые необходимы для логического раздела. (обычно один трек, 63 сектора и плюс один сектор, как минимум.)

2. На жестком диске нет расширенного раздела или основной раздел для преобразования находится рядом с расширенным разделом.

Логический в основной.

Чтобы преобразовать логический раздел в основной, должны быть соблюдены следующие требования:

1. После преобразования, количество основных разделов не должно превышать четырех (включая ситуацию, что существует только один логический раздел на текущем диске).

2. Логический раздел размещают на конце расширенного раздела. Только когда вышеуказанные требования соблюдены, будет доступна соответствующая опция, или они будут окрашены в серый цвет.

Эта функция не относится к GPT диска (GUID таблицы разделов).

Чтобы сделать преобразование, сначала выберите раздел, котор нужно преобразовать. Затем "Раздел" в главном меню; выберите пункт "Преобразовать в логический" или "Преобразовать в Основной". PartitionGuru мгновенно завершит преобразование.

Чтобы избежать ошибочных операций, после преобразования PartitionGuru сохраняет изменения в памяти, пока вы не выполните команду "Сохранить таблицу разделов".


19. Óäàëåíèå äàííûõ (ïåðåçàïèñü ñåêòîðîâ)

19. Удаление данных (перезапись секторов)

 Top Previous Next

PartitionGuru может стереть данные из любого раздела или диска. Стертые данные никогда не смогут быть восстановлены, с помощью любого программнного обеспечения. При стирании данных, можно назначить символы для заполнения секторов. Для выполнения этой функции, выберите раздел или диск, на котором вы хотите стереть данные и нажмите в главном меню «Инструменты» «Стереть сектора».

В PartitionGuru появится диалоговое окно:

В этом диалоговом окне можно задать следующие параметры:

-Изменить раздел или диск, на котором нужно стереть данные.

-Назначить диапазон секторов, чтобы стереть данные. При выборе номера сектора означает начальный сектор раздела.

-Назначить символы, которыми заполняют сектора.

Нажмите "Стереть" для выполнения этой функции. PartitionGuru покажет предупреждение:

Внимательно прочитайте сообщение. Если вы действительно хотите стереть данные, нажмите кнопку «Стереть».


Îïåðàöèè ñ äèñêîì

Операции с диском

PartitionGuru поддерживает следующие операции с дисками:

1. Поиск потерянных разделов (восстановление разделов)

2. Восстановление главной загрузочной записи (восстановление MBR)

3. Восстановление разделов

4. Клонирование диска

5. Резервное копирование и восстановление таблицы разделов

6. Сделать загрузочный USB диск

7. Проверка и ремонт поврежденных секторов

8. Удалить все разделы

9. Очистить зарезервированные сектора

10. Преобразовать таблицу разделов

11. Проверить и исправить таблицу разделов


1. Ïîèñê ïîòåðÿííûõ ðàçäåëîâ

1. Поиск потерянных разделов

"Восстановить таблицу разделов" - переписать с помощью оригинальной версии DOS. Эта функция восстанавливает разделы и таблицу разделов через загрузочные сектора потерянных или удаленных разделов. Удаленные или потерянные разделы вызванные воздействием вируса так же могут восстановлены с помощью этой функции.

Информация о местоположении раздела находится в таблице разделов. Когда раздел будет удален, это удалена информация о местоположении раздела, но данные из него не удаляются. PartitionGuru считает из загрузочных секторов потерянных разделов тип раздела и размер, анализируя информацию загрузочных секторов и других секторов, таким образом, что раздел может быть восстановлен.

Эта функция является визуальной, гибкой и комплексной. Доступно копирования файлов из разделов, которые найдёт PartitionGuru без сохранения таблицы разделов, эти удаленные файлы могут быть восстановлены. В процессе сканирования, PartitionGuru отображает раздел и вы можете просматривать файлы.

Чтобы восстановить раздел, выберите жесткий диск, который требует восстановления раздела. Метод заключаются в следующем:

1. Нажмите на элемент диска в левой панели «Разделы и дерева папок», или на любой элемент, принадлежащий к диску.

2. Щелкните на стрелку в верхней левой части панели «Структура разделов диска» для переключения диска. Если нужно найти раздел на свободном пространстве, выберите свободное пространство на «Структура разделов диска».

Выберите пункт меню «Инструменты» «Поиск потерянных разделов (восстановление разделов)», или выберите «Поиск потерянных разделов (восстановление разделов)» в контекстном меню. В PartitionGuru появится диалоговое окно:

Диапазон поиска:

1. Весь диск: Игнорировать существующие разделы, поиск по диску от начала до конца.

2. Всё свободное пространство: Сохранять существующие разделы и поиск потерянных разделов в свободном пространстве.

3. Выбранное пространство: Сохранить существующие разделы и восстанавливать удаленные разделы в выбранном свободном пространстве.

4. Диапазон цилиндров: Восстановление разделов из указанного диапазона цилиндров.

Чтобы быть уверенным, что все восстановленные разделы были выровнены по цилиндрам, вы можете включить опцию "Выравнивать разделы только по цилиндрам", это может улучшить скорость поиска. В общем, выравнивание по цилиндрам нужно в разделах операционной системы XP, Vista и более поздние системы в выравнивании не нуждаются.

Когда будет найден раздел, PartitionGuru покажет его в интерфейсе, в тоже время будет показано всплывающее окно:

Если есть файлы в разделе, которые только что найдены, PartitionGuru автоматически перейдёт на окно «Файлы», в список файлов удаленного раздела. Вы можете просматривать файлы в разделе, не закрывая диалогового окна. Если это тот раздел, который вы ищете, нажмите кнопку "Бэкап", в противном случае нажмите "Игнорировать", чтобы пропустить этот раздел. PartitionGuru не сохранит таблицу разделов (не запишет на диск), после того, как вы нажмете "Бэкап", он сохраняется в памяти. Иногда в диалоговом окне появится выбор, "Это первичный раздел»" или "Это логический раздел», проверьте этот выбор, если он будет не соответствовать действительности (не как его оригинал), вы можете переназначить его.

Процесс поиска будет продолжаться для восстановления других потерянных разделов, до завершения задачи поиска. Когда она будет завершена, появится всплывающее сообщение:

Вы можете просматривать файлы из раздела с использованием PartitonGuru, без сохранения таблицы разделов, копировать или восстановить удаленные файлы. Только при сохранении таблицы разделов раздел будет доступен для операционной системы.

Если вы хотите отменить результаты поиска, нажмите пункт меню "Диск" - "Перезагрузить текущий жёсткий диск".


2. Âîññòàíîâëåíèå MBR

2. Восстановление MBR

Главная загрузочная запись (MBR) находится в первом секторе, который используется для выбора и загрузки операционной системы. PartitionGuru исследует MBR при сохранении таблицы разделов и восстановит автоматически, если MBR окажется повреждённой. Нет необходимости восстанавливать MBR специально для разделения нового жесткого диска в PartitionGuru. Эту функцию можно использовать для восстановления повреждённой MBR, или если вам нужно очистить загрузочную запись MBR. Шаги следующие:

Нажмите «Диск»,-> «Восстановить главную загрузочную запись», в PartitionGuru появится всплывающее окно сообщения:

Нажмите «Да» и PartitionGuru восстановит главную загрузочную запись, создав MBR.


3. Âîññòàíîâëåíèå ðàçäåëîâ

3. Восстановление разделов

При удалении раздела все данные удаленного раздела не стирается с диска. Очищается только индекс удаленного раздела. Поэтому с помощью PartitionGuru можно попытаться восстановить удаленный раздел, анализируя остатки данных. Почти все удаленные разделы могут быть восстановлены без дальнейших разрушений.

Функция «Восстановление потерянных разделов (восстановление разделов)» является одной из основных функций программного обеспечения PartitionGuru. Операция «Восстановить удаленный раздел» визуально гибкая и объёмная. Когда будет найден потерянный раздел, все атрибуты раздела, включая все файлы, будут отображены. Вы можете проверить размер и тип раздела и даже можете просматривать все файлы и папки для проверки, определить является ли раздел тем потерянным, который вы ищете. Панель в правой нижней части рамки окна - это окно эскизов. Оно отображает данные каждого файла в шестнадцатеричном формате и эскиз графического или текстового файла. Все эти данные являются базовыми, при условии, что таблица разделов не сохраняется на диск! Для предотвращения дальнейшего разрушения, ничего не будет записано на диск. Вся информация загружается в память, пока вы не нажмёте команду «Сохранить таблицу разделов» или «Сохранить».

Если вы хотите восстановить потерянные разделы, PartitionGuru является лучшим выбором. Это мощный инструмент для восстановления потерянных разделов. Вот описание восстановление разделов с помощью программного обеспечения PartitionGuru. Выберите диск, на котором был потерян раздел . Существует два способа выбрать диск:

1. Нажмите на элемент диска в левой панели «Разделы и дерева папок», или на любой элемент, принадлежащий к диску.

2. Щелкните на стрелку в верхней левой части панели «Структура разделов диска». В случае, если все разделы диска были потеряны, вы можете выбрать поиск только нажав на «свободное» пространство.

Чтобы начать процесс поиска, нажмите «Раздел» на панели инструментов, или пункт меню «Инструменты-> Поиск потерянных разделов (восстановление разделов)», или щелкните правой кнопкой мыши и выберите из всплывающего меню «Поиск потерянных разделов (восстановление разделов)». Появится всплывающее окно:

Диапазон поиска:

1. Весь диск: Игнорировать существующие разделы, поиск по диску от начала до конца.

2. Всё свободное пространство: Сохранять существующие разделы и поиск потерянных разделов в свободном пространстве.

3.Выбранное пространство: Сохранить существующие разделы и восстанавливать удаленные разделы в выбранном свободном пространстве.

4.Диапазон цилиндров: Восстановление разделов из указанного диапазона цилиндров.

Если диапазон поиска установлен, нажмите кнопку "Пуск", чтобы начать процесс восстановления раздела.

Когда будет найден раздел, PartitionGuru покажет его в интерфейсе, в тоже время будет показано всплывающее окно:

Если есть файлы в разделе, которые только что найдены, PartitionGuru автоматически перейдёт на окно «Файлы», в список файлов удаленного раздела, в то же время будет открыта панель эскизов. Вы можете войти в фоновые окна и проверить файлы в ней, не закрывая это окно сообщения, так же можете проверить расположение папки, предварительно просмотреть изображения и текстовые файлы и т.д. Если это тот раздел раздел, который вы ищете, нажмите кнопку "Бэкап", в противном случае нажмите "Игнорировать", чтобы пропустить этот раздел. Обратите внимание, что «Бэкап» не означает сохранение на диск, он сохраняется в памяти. Таким образом, весь процесс поиска является безопасным.

Иногда в сообщении такой вариант, как: «Это первичный раздел» или «Это логический раздел» будет не соответствовать действительности (не как его оригинал), вы можете переназначить его.

Процесс поиска будет продолжаться для восстановления других потерянных разделов, до завершения задачи поиска. Когда она будет завершена, появится всплывающее сообщение:

Результат поиска не будет сохранён на диске, он только сохранится в памяти. В то же время можно получить доступ к файлам в разделах, которые найдены и даже см. Восстановить потерянные файлы. Результаты поиска вступят в силу в операционной системе после команды "Сохранить" или "Сохранить таблицу разделов".

Если вас не устраивает искомый результат, нажмите в меню "Диск - Перезагрузить текущий жесткий диск". Вы можете попробовать другие варианты поиска, задав несколько различных вариантов, пока потерянные разделы не будут восстановлены.


4. Êëîíèðîâàíèå äèñêà

4. Клонирование диска

Клонирование диска означает, клонирование всех разделов, файлов и других данных на другой диск. В процессе клонирования PartitionGuru будет создавать разделы с тем же размерм и типом целевого диска, в соответствии структуры разделов исходного диска. Затем он будет копировать файлы и данные в разделы по одному. PartitionGuru предоставляет три режима клонирования данных.

1.Копирования всех секторов. Копирование всех слоёв исходного диска на целевой диск от начала до конца, даже если раздел имеет повреждённые данные. Этот метод будет копировать так же большое количество недействительных данных, таким образом, это займет много времени. Но это наиболее полный метод копирования, которым можно скопировать все данные исходного диска на целевой диск.

2.Копирование действительных секторов структуры файловой системы. Копирование всех действительных данных с исходного диска на соответствующие разделы целевого диска согласно структуры файловой системы. Структура целевого раздела будет точно такой же, как и исходного раздела. PartitionGuru будет избавляться от поврежденных секторов при копировании данных. Этот режим является самым быстрым, он копирует только действительные сектора.

3.Копирование всех файлов. Копирование всех данных исходного диска на целевой диск, анализируя расположения файловой системы диска источника. При копировании данных, PartitionGuru упорядочивает файлы целевого раздела с учетом расположения файловой системы. Там не будет фрагментированных файлов и это довольно быстрый режим.

Если тип файловой системы раздела не поддерживается PartitionGutu, при копировании раздела он примет режим копирования всех секторов, который гарантирует, что разделы исходного и целевого диска будут одинаковы.

Необходимо, чтобы объем целевого диска был не меньше, чем исходного.

Чтобы скопировать диск, выберите пункт меню «Инструменты» - «Клонировать диск», в PartitionGuru появится диалоговое окно:

В то же время появится диалоговое окно для выбора исходного и целевого диска, как показано ниже:

После выбора исходного и целевого диска, PartitionGuru вернётся в диалоговое окно "Клонировать диск". Выберите один из режимов копирования и нажмите "Пуск". PattitionGuru покажет следующее предупреждение:

Убедитесь, что нет важных данных на целевом диске или вы уже сделали их резервные копии, а затем нажмите кнопку «ОК». PartitionGuru попробует блокировать все разделы обоих дисков. Если разделы на диске-источнике не могут быть заблокированы (обычно, включая раздел, где установлена операционная система или PartitionGuru), PartitionGuru покажет предупреждающее сообщение:


5. Ðåçåðâíîå êîïèðîâàíèå

5. Резервное копирование и восстановление таблицы разделов

PartitionGuru позволяет создавать резервные копии и восстанавливать таблицу разделов. Он может создать резервную копию таблицы разделов и загрузочного сектора всех разделов на диске в файл. Когда данные будут повреждены, вы можете восстановить данные из резервной копии.

1 Резервное копирование таблицы разделов:

Выберите диск, с которого вы хотите создать резервную копию таблицы разделов, пункт меню «Диск» - «Резервное копирование таблицы разделов» или можете нажать клавишу F9. PartitionGuru покажет диалоговое окно:

Введите имя файла и нажмите кнопку «Сохранить», в PartitionGuru появится следующее сообщение, показывающее, успешное создание резервной копии таблицы разделов. Просьба сохранять файл, что бы его можно использовать для восстановления данных позднее.

2 Восстановление таблицы разделов:

Выберите диск, который нуждается в восстановлении таблицы разделов, пункт меню «Диск»-> «Восстановить таблицу разделов» или нажать клавишу F10. В PartitionGuru всплывёт диалоговое окно «Выберите бэкап таблицы разделов». После выбора нужного файла, PartitionGuru покажет диалоговое окно:

Проверьте, является ли раздел тем, который вы хотите восстановить, до начала восстановления таблицы разделов. Нажмите кнопку «Да», PartitionGuru спросит, хотите ли вы "восстановить загрузочные сектора?". Выберите в соответствии с потребностями.

Обратите внимание: после создания резервной копии таблицы разделов, если какие-либо разделы будут отформатированы с другими параметрами, такими как: размер кластера, может быть изменён загрузочный сектор после форматирования - в этом случае, загрузочный сектор будет разрушен этим восстановлением.

Нажмите кнопку "Нет", если вы не хотите восстановить загрузочные сектора для разделов. Тогда только таблица разделов, в том числе размер и положение каждого раздела будут восстановлены. Загрузочный сектор раздела останется неизменным. Если вы выберите "Отменить", PartitionGuru откажется от восстановление и не будет изменена таблица разделов и загрузочные сектора разделов.


6. Ñäåëàòü çàãðóçî÷íûé USB äèñê

6. Сделать загрузочный USB диск

С помощью PartitionGuru можно сделать загрузочные USB, такие как: USB-FDD, USB-ZIP и USB-HDD. Эта функция обращается в режиме FDD или ZIP флэш-диск USB (или USB жесткий диск) и создаёт загрузочную DOS, которая может использована для загрузки компьютера. Для компьютеров, поддерживающих загрузки с USB, такой загрузочный диск может использоваться для восстановлении системы. В настоящее время производители материнских плат имеют согласованные стандарты в режиме загрузки USB; HDD, FDD, ZIP и сегодня являются популярными режимами. Вы можете выбрать любой, поддерживаемый материнской платой режим.

Если имеются какие-либо файлы на диске USB (или карте памяти), скопируете их сначала на жесткий, поскольку они будут уничтожены с помощью следующего процесса.

1. Сделать USB-FDD загрузочный диск. Выберите флэш-USB диск или переносной жесткий диск, затем нажмите в меню «Инструменты» «Создать загрузочный диск USB-FDD". PartitionGuru покажет предупреждающее сообщение. Создайте резервную копию важных данных перед преобразованием.

Нажмите «Да», появится диалоговое окно:

После выбора файловой системы можно нажать кнопку «Конвертировать». Можно задать размер кластера и метку тома, аналогично операции форматирования разделов. PartitionGuru начнёт конвертирование сразу после нажатия кнопки «Конвертировать». Далее он будет копировать DOS загрузочные файлы на диск. Завершив операцию, PartitionGuru покажет сообщение: Просьба вынуть диск и вставить его снова.

2.Сделать USB-ZIP загрузочный диск. Выберите флэш-диск USB (или переносной жесткий диск), нажмите в меню "Инструменты" "Создать загрузочный диск USB-ZIP"; или щелкните правой кнопкой мыши и выберите пункт "Создать загрузочный диск USB-ZIP". Остальные шаги такие же, как в "Сделать загрузочный диск USB-FDD".

3.Сделать USB-HDD загрузочный диск. HDD режим является режимом загрузки жесткого диска. При запуске компьютера, он загружает с жесткого диска главную загрузочную программу, которая ищет активный раздел и право загрузки передается операционной системе активного раздела. Как правило преобразование не является необходимым, достаточно то, что вы должны сделать, это создать раздел и отформатировать его, на котором создается система DOS.

Если текущий диск работает в режиме FDD или ZIP, эта функция может преобразовать его в режим HDD. Подробные шаги заключаются в следующем:

Выберите USB флэш-диск или переносной жесткий диск, пункт в меню «Инструменты» «Создать загрузочный диск USB-HDD» или выберите этот пункт в всплывающем меню правой кнопкой мыши. ParrtitionGuru покажет следующее предупреждающее сообщение. Cоздайте резервную копию важных данных перед преобразованием.

Нажмите кнопку «Да» и PartitionGuru преобразует диск в режим жесткого диска, затем попросит поттверждение создания загрузочного раздела, как показано ниже:

Нажмите кнопку "Нет", PartitionGuru не создаст раздел и вы можете использовать диск в обычном режиме. Если вы нажмете "Да", появится диалоговое окно "Создание нового раздела":

После выбора типа файловой системы и размера раздела, нажмите кнопку «ОК», PartitionGuru создаcт новый раздел, отформатирует и скопирует систему DOS на вновь созданный раздел. Преобразование в режим HDD будет закончено!


7. Ïðîâåðêà è ðåìîíò Bad Ñåêòîðîâ

7. Проверка и ремонт поврежденных секторов

Сектор - самая маленькия единица на жестком диске, в которой хранятся данные. Дефектный сектор на жестком диске возникает, когда этот сектор считается как несуществующий, то есть невозможно обращение к нему. Обусловлено неверным форматом физического адреса, записанного для данного сектора, ошибка контрольной суммы для него и т.д. Другая причина дефектных секторов на жестком диске - физическое повреждение. Существует много типов ошибок, которые могут появляться из-за проблемы с жестким диском. Если есть ошибки, но в работе жёсткого диска не слышен посторонний скребущий шум, это вполне может быть проблемой, которая может решена с помощью программного приложения. Но если есть определенный шум при работе жесткого диска, это может быть серьезной проблемой аппаратного средства, которая должна быть восстановлена в профессиональной ремонтной мастерской PC. Если ваш жесткий диск находится на гарантии, вы можете восстановить его бесплатно. На повреждённых секторах данные потеряны и становятся недоступными, но данные на других секторах диска остаются как есть.

PartitionGuru предоставляет функцию проверки плохих секторов, а также ограниченную функцию ремонта поврежденных секторов. Чтобы использовать эту функцию, нажмите в меню пункт «Диск» - «Проверка или ремонта поврежденных секторов», PartitionGuru покажет диалоговое окно:

Выберите диск, который нужно проверить и введите диапазон проверки (цилиндры), затем нажмите кнопку "Начать проверку". PartitioGuru отобразит детальную информацию о дефектных секторах. Проверка будет замедлена, при обнаружении поврежденных секторов.

Завершив, PartitionGuru выведет число поврежденных секторов:

Вы можете нажать на кнопку "Сохранить", чтобы сохранить отчет в текстовый файл. Кроме того можно нажать кнопку «Сохранить отчет» и сохранить отчет в файл пользовательского формата. Затем можете нажать кнопку «Открыть отчет» и проверить отчет текущего интерфейса.

Если вы хотите попробовать восстановить плохие сектора, нажмите «Восстановить», в PartitionGuru будет показано сообщение:

Важное замечание: ремонт уничтожит данные, сохраненные на или вблизи поврежденных секторов! Если возможно, сделайте резервное копирование данных. Если есть важные данные на поврежденных секторах, не используйте эту функцию, чтобы восстанавливать поврежденные сектора, вы должны отправить ваш диск профессионалам по восстановлению данных . Потому что, ремонт поврежденных секторов уничтожает данные, их потом не восстановить! Кроме того, вы должны знать, что не все плохие сектора могут быть восстановлены с помощью этой функции.

Для обеспечения сохранности данных, не рекомендуется использовать диск с поврежденными секторами, хотя он был отремонтирован. Не сохраняйте важные данные на диске.

Чтобы сэкономить время, эту функцию можно использовать для ремонта поврежденных секторов без проверки или после проверки с помощью другого программного обеспечения.

Если успешно исправлены поврежденные сектора, PartitionGuru отметит их как «Исправленные» в отчёте.

Когда восстановление будет закончено, PartitionGuru выведет число дефектных секторов, которые восстановил. Пожалуйста, проверьте фактические результаты восстановления.


8. Óäàëèòü âñå ðàçäåëû

8. Удалить все разделы

Эта функция удалит все разделы текущего диска за один проход.

Выберите диск, на котором вы хотите удалить все разделы, затем выберите пункт меню «Диск» - «Удалить все разделы». PartitionGuru покажет следующее сообщение:

Если вы уверены что нет важных данных на текущем диске или они зарезервированы, нажмите кнопку «Да», чтобы завершить удаление всех разделов.

Для предотвращения потери данных, из-за неправильной манипуляции, изменения не будут сохранены на диск сразу, они сохранятся в памяти до тех пор, пока вы не выполните команду «Сохранить таблицу разделов».


9. Î÷èñòèòü çàðåçåðâèðîâàííûå ñåêòîðà

9. Очистить зарезервированные сектора

Для PartitionGuru к зарезервированным секторам относятся сектора, начиная от второго сектора (после сектора MBR) до сектора, который находится перед началом сектора первого раздела. В большинстве случаев трек имеет 63 сектора и первый раздел обычно начинается с 63-го сектора, таким образом, исключая сектор MBR, существует 62 сектора, которые будут очищены.

Относительно случая, что секторов не 63 или первый раздел начинается не с 63-го сектора, PartitionGuru автоматически вычислит число секторов, которые будeт очищены так, чтобы не очистить другие сектора, кроме зарезервированных.

Выберите диск, который вы хотите очистить от зарезервированных секторов, нажмите кнопку «Диск» - «Очистить зарезервированные сектора», в PartitionGuru появится следующее сообщение:

Нажмите "OK", чтобы выполнить операцию.

Эта функция не применима к GPT-дискам с таблицей GUID разделов.


10. Ïðåîáðàçîâàòü ñòèëü òàáëèöû ðàçäåëîâ

10. Преобразовать стиль таблицы разделов

PartitionGuru поддерживает стандартные MBR и GUID таблицы разделов и может конвертировать без потерь данных между этими двумя типами.

Преобразование не повреждает данные. Но операционная система, которая не поддерживает GUID таблицу разделов не сможет увидеть разделы и файлы !

1. Преобразование таблицы разделов в GUID.

Эта функция применяется для преобразования таблицы разделов в GUID. Перед преобразованием должно быть зарезервированно свободное пространство (по 33 сектора, не считая MBR-сектора) до и после данных на диске. Для выполнения этой функции нажмите «Диск» - «Преобразовать в таблицу разделов GUID», появится сообщение:

Убедитесь, что после преобразования диска операционная система поддерживает таблицу разделов GUID, в противном случае диск станет недоступным! Нажмите «OK» для завершения преобразования. Изменение сохранится только после команды "Сохранить таблицу разделов".

2. Преобразование таблицы разделов в MBR.

Функция используется для преобразования таблицы разделов в MBR. Это преобразование имеет ограничения (например, число первичных раздела не может превышать четыре). Если существует более 4 х - первичных разделов, PartitionGuru изменит их на логические разделы. Преобразованная таблица разделов будет с ошибкой, если PartitionGuru не сможете изменить их на логические разделы (как правило, потому, что нет свободного места до раздела).

Выберите диск, который вы хотите конвертировать и нажмите в меню «Диск» «Преобразовать в таблицу разделов MBR». В PartitionGuru будет показано окно сообщения:

Если емкость диска более чем 2 ТБ, после преобразования, пространство, объемом более 2 ТБ, может не использоваться. Кроме того, если на диске устанавлена операционная система на основе EFI BIOS, она не загрузится после преобразования.

Если нет ошибок, нажмите "OK", чтобы начать преобразование.


11. Ïðîâåðèòü è èñïðàâèòü îøèáêè òàáëèöû ðàçäåëîâ

11. Проверить и исправить ошибки таблицы разделов

С помощью PartitionGuru можно проверить и исправить ошибки в таблице разделов. Если диск имеет серьезные ошибки, PartitionGuru сообщит об них сразу после запуска.

Чтобы выполнить проверку вручную, выберите диск, который вы хотите проверить, в меню "Инструменты" -"Проверить таблицу разделов на ошибки". PartitionGuru начнёт проверку таблицы разделов текущего диска. Если не будут найдены ошибки, появится сообщение - Ошибок не найдено.

При наличии ошибок, будет показано диалоговое окно «Отчет об ошибках таблицы разделов»:

Если найденые ошибки могут быть исправлены. в PartitionGuru, будет активна кнопка "Исправить". Вы можете нажать на кнопку, чтобы исправить ошибки, или в противном случае сделать это вручную, следуя подсказкам.


Ðåäàêòîð ñåêòîðîâ äèñêà

Редактор секторов диска

PartitionGuru поддерживает следующие операции редактора секторов диска:

1. Краткий обзор

2. Общие функции

3. Контекстное меню


1. Êðàòêèé îáçîð

1. Краткий обзор

Краткий обзор

Примечание: правка секторов относится к степени операции высокого риска, таким образом, не используйте эту функцию, если не имеете соответствующих знаний.

Выберите раздел и нажмите кнопку "Hex редактор " для начала редактирования секторов.

Эта функция состоит из пяти частей:

1.Панель инструментов

Слева направо: сохранить, копировать, вставить, отменить, найти шестнадцатиричное значения, найти текст, перейти к смещению, перейти к сектору, предыдущий сектор, следующий сектор, перейти к первому сектору, перейти к последнему сектору, последний курсор, следующий курсор, интерпретировать как начало раздела, преобразование байт, калькулятор и просмотр каталога.

2.Просмотр каталога

Показывает файлы и папки раздела, сектора которых редактируются. Место выбранного элемента можно определить с помощью контекстного меню (начало сектора файла, запись файла, индекс, родительская запись каталога, запись в каталоге и начало сектора родительского каталога). Дважды щелкните на папку, чтобы посмотреть в ней файлы, нажмите на папку со знаком «..», чтобы вернуться в родительский каталог.

3.Интерпретатор

Эта область интерпретирует текущую позицию курсора. Когда нужные данные вводятся в поле ввода, интерпретатор автоматически преобразовывает его в соответствующее шестнадцатеричное значение и записывает его в таблицу, что экономит время ручного преобразование. Ниже приведены типы, которые он может интерпретировать:

1) Знаковые и безнаковые (8 бит, 16 бит, 24 бита, 32 бита, 40 бит, 48, 56, 64 бит).

2) GUID: GUID (глобальный уникальный идентификатор) —128-битный идентификатор числа, произведенный по алгоритму.

3) Время и дата: дата - это 32-битное значение, представляющее число секунд, прошедших с 1 января 1970 года. DOS дата - используется при вызове нескольких функций DOS и всех файловых систем FAT. Нижнее слово определяет время, верхнее слово дату. Структура FILETIME - 64-битовое значение, представляющее число интервалов по 100 наносекунд с 1 января 1601 (универсальное глобальное время (UTC)). Используется в Win32 API.

4) Двоичное число.

4.Редактор

Эта область состоит из трёх частей: область смещения, hex редактор и редактор текста. Поддерживается перетаскивание мышью. Измененные части изменят цвет с чёрного на красный.

1) Область смещения: показывает адрес в шестнадцатеричном виде.

2) Hex редактор: пользователь может ввести символы (0-9 и A-F).

3) Область редактирования текста : пользователь может ввести символы (ASCII).

4) Вызов контекстного меню.

5.Строка состояния

Эта область показывает текущий сектор и количество секторов, смещение, интерпретацию текущего курсора, диапазон выбранных блоков и размера блока. Также она поддерживает копирование через правую кнопку мыши (шестнадцатеричные и десятичные).


2. Îáùèå ôóíêöèè

2. Общие функции

Общие функции

Для удобства использования PartitionGuru содержит кнопки для редактирования секторов:

Далее объясняется, как использовать эти кнопки в деталях.

1.Местоположение сектора

a. 4 Найти шестнадцатиричное значение

Введите соответствующие условие для поиска hex значений, как показано ниже:

1). Поддержка поиска по нескольким критериям.

2). Шаблон часто используемого поискового содержания.

3). Поддержка групповых символов.

4). Поддержка поиска во всех направлениях: все, вверх и вниз.

5). Поддержка настройки поиска смещения.

6). Поддержка выбора условий: "По одному" или "Сразу все".

b. Поиск текста

Быстро найти необходимый текстовый фрагмент, как показано ниже:

1). Поддержка поиска по нескольким критериям.

2). Поддержка поиска через соответствующий пример.

3). Поддержка групповых символов.

4). Поддержка поиска во всех направлениях: все, вверх и вниз

5). Поддержка настройки поиска смещения.

c. 7 Перейти к смещению

Значение введённое в раскрывающемся список сохраняется после перехода и может быть выбрано в следующий раз, когда диалоговое окно снова будет открыто.

1). Единицы: байт, слово, DWORD, QWORD и сектора.

2). Масштаб: десятичные и шестнадцатеричные.

3). По отношению к: начало (с начала), текущая позиция, текущая позиция (назад от) и конец (назад от).

d. Перейти к сектору

Быстро перейти к указанному сектору, как показано ниже.

1).Логический (LBA): необходимо ввести номер сектора или кластера (включается только тогда, когда раздел открыт).

2). Физический (CHS): необходимо ввести параметры «цилиндр/дорожка», «головка/поверхность» и «сектор».

e. Перейти к сектору

Перейти к предыдущему или следующему сектора и перейти к первому или последнему сектору.

f. Быстрый переход курсора

Перейти к следующему или последнему курсору.

2.Редактирование секторов

Данные о секторе, где курсор остается, можно просматривать и редактировать.

Как показано на рисунке выше, смещение, шестнадцатеричные значения и последующая интерпретация курсора можно увидеть в нужном интерфейсе. Вы можете редактировать эти данные, когда курсор находится в текстовой области редактирования или области hex редактора.

a. Копировать и вставить

Наведите курсор на начало сектора и перетащите кнопкой мыши к окончанию определенной области данных, выбранная область изменит цвет в светло-голубой.

Нажмите кнопку [image] «Копировать», чтобы скопировать данные из выбранной области в буфер обмена, затем наведите курсор в начало целевой области и нажмите кнопку [image] “Вставить ".

Скопированные данные:

b. Сохранить и отменить

Эти операции с секторами не изменит данные на жестком диске, прежде чем вы нажмёте кнопку [image] “Сохранить ", или операции могут быть отменены после нажатия на кнопку [image] ”Отменить”

Предупреждение: Данные будут изменены навсегда, после нажатия кнопки "Сохранить" и они не обратимы, так что будьте осторожны !

3. Другие

a. Интерпретатор как начало раздела

Эта функция интерпретирует текущий сектор, где находится курсор, как начало раздела. Если данные сектора соответствует функции данных начала раздела, система будет определять размер раздела автоматически, в противном случае система будет просить вас ввести размер раздела. Интерпретируемые разделы будут перечислены на левом интерфейсе светлее, чем обычные разделы.

b. Преобразование байтов

Преобразование байтов влияет на перевод данных, которые сохраняются в обратном порядке по умолчанию.

1).Little-Endian (от младшего к старшему), байт младшего разряда сохранен в памяти по самому низкому адресу и старший байт по самому высокому адресу.

2). Big-Endian (от старшего к младшему), старший байт числа, сохраняется в память в наименьший адрес, и младший байт в высший адрес.

c. Калькулятор

Используйте калькулятор для быстрого вычисления секторов.

d. Просмотр каталога

Эта область показывает файлы и папки раздела.


3. Êîíòåêñòíîå ìåíþ

3. Контекстное меню

Контекстное меню

PartitionGuru предоставляет контекстное меню для облегчения редактирования секторов.

1.Контекстное меню списка каталога

Это меню включает в себя наиболее часто используемые функции, а также функции редактирования секторов.

a. Начальный сектор файла: перейти в первый сектор, где выбранный пункт фиксируется.

b. Запись файла (активно, когда файловая система NTFS): перейти к сектору записи файла, где выбранный пункт фиксируется.

c. Индекс (активно, когда файловая система NTFS): перейти к сектору индексной записи, где выбранный пункт фиксируется.

d. Запись родительского каталога (активно, когда файловая система NTFS): перейти к сектору записи родительского каталога, где выбранный пункт фиксируется.

e. Запись каталога (активно, когда файловая система FAT): перейти к сектору записи каталога, где выбранный элемент фиксируется.

f. Начальный сектор родительского каталога (активно, когда файловая система FAT): перейти к сектору начала родительского каталога, где выбранный пункт фиксируется.

2. Контекстное меню области редактирования секторов

Это меню показано на следующем рисунке:

a. Выбор данных

1). Начало блока: при выборе данных, принять текущий курсор в начале блока.

2). Конец блока: при выборе данных, принять текущий курсор в конец блока.

3). Выделить все: выбор всех блоков.

4). Снять выделенное: отменить выбор всех блоков.

b. Копирование и запись

Меню для копирования блока находится ниже:

1). Как текст: копирования блоков в виде текста.

2). В новый файл: сохранить область выделенной области в новый файл.

3). Значение Hex: копирование выделенной области в виде шестнадцатеричных значений.

4). Как отображает редактор: скопировать в текстовый файл, сохранив стиль редактора секторов.

Меню для записи блока на следующем рисунке:

1). Записать Hex: записать выделенную область в назначенный район HEX.

2). Записать текст: записать выделенную область в назначенный район текста.

c. Перейти на смещения и заполнить блок

1). Перейти на смещение: перейти в область указанного смещения бит, как показано ниже:

2). Перейти к сектору: перейдите в область заданного сектора на бит, как показано ниже:

3). Заполнить блок: затереть выбранную область

3. Быстрый доступ в строке состояния

Нажмите на строку состояния в нижней части интерфейса для выполнения соответствующих операций:

a. Сектор: нажмите на область, чтобы перейти в окно диалога выбора сектора или щелкните правой кнопкой мыши, чтобы скопировать номер текущего сектора или количество секторов.

b. Смещение: нажмите на область, чтобы перейти в окно диалога перехода к смещения или щелкните правой кнопкой мыши, чтобы скопировать текущее смещение в шестнадцатеричном или десятичном значении.

c. Интерпретация: знаковая и беззнаковая.


Âèðòóàëüíûé äèñê è îïåðàöèè ñ ôàéëàìè îáðàçà

Виртуальный диск и операции с файлами образа

PartitionGuru поддерживает следующие операции с виртуальными дисками и файлами образа.

1. Создать файл виртуального диска VMware

2. Создать файл виртуального диска Virtual PC

3. Создать файл виртуального диска VirtualBox

4. Создать ".Img" диск или файл образа раздела

5. Файл виртуального диска и его разделов


1. Ñîçäàòü ôàéë âèðòóàëüíîãî äèñêà VMware

1. Создать файл виртуального диска VMware

PartitionGuru поддерживает создание файла виртуального диска VMware, его разделов и файлов.

Нажмите «Диск»,--> «Создать новый файл виртуального диска «--> «Создать VMWare файл виртуального диска» и PartitionGuru покажет диалоговое окно:

Вы можете задать путь к файлу, имя файла, размер, версию и тип адаптера, можете задать опции "Выделить все дисковое пространство" и "Разделитьть диск на файлы по2 Гб". Все эти параметры такие же, как и создание диска с помощью VMware Workstation.

Нажмите кнопку "Создать" и файл виртуального диска будет создан. PartitionGuru откроет вновь созданный файл сразу после ее создания, также его можно открыть, нажав "Диск" -> "Открыть файл виртуального диска".

Для того, чтобы открыть ранее созданный виртуальный диск обратитесь в "Файлы виртуального диска и его разделов".


2. Ñîçäàòü ôàéë âèðòóàëüíîãî äèñêà VirtualPC

2. Создать файл виртуального диска VirtualPC

PartitionGuru поддерживает создание файла виртуального диска Virtual PC («VHD»-файл), его разделов и файлов.

Нажмите «Диск»,-> «Создать новый файл виртуального диска «-> «Создать Virtual PC файл виртуального диска» и PartitionGuru покажет диалоговое окно:

Задайте путь к файлу, имя файла и размер. Кроме того вы можете задать опцию «Выделить все дисковое пространство».

Нажмите кнопку "Создать" и файл виртуального диска будет создан. PartitionGuru откроет этот вновь созданный файл. Также вы можете открыть его, нажав на "Диск" - "Открыть файл виртуального диска".

Для того, чтобы открыть ранее созданный виртуальный диск обратитесь в "Файлы виртуального диска и его разделов".


3. Ñîçäàòü ôàéë âèðòóàëüíîãî äèñêà VirtualBox

3. Создать файл виртуального диска VirtualBox

PartitionGuru поддерживает создание файла виртуального диска VirtualBox (файл «.vdi»), его разделов и файлов.

Выберите в меню «Диск"-> «Создать новый файл виртуального диска «-> «Создать VirtualBox файл виртуального диска», появится следующее диалоговое окно:

Задайте путь к файлу, имя файла и размер. Кроме того вы можете задать опцию «Выделить все дисковое пространство».

Нажмите кнопку "Создать" и файл виртуального диска будет создан. PartitionGuru откроет вновь созданный файл. При необходимости, можно также выбрать пункт меню "Диск" -"Открыть файл виртуального диска".

Для того, чтобы открыть ранее созданный виртуальный диск обратитесь в "Файлы виртуального диска и его разделов".


4. Ôàéëû âèðòóàëüíîãî äèñêà è åãî ðàçäåëîâ

4. Файлы виртуального диска и его разделов

PartitionGuru поддерживает файлы виртуальных дисков VMWare, ".img" файлы образа диска и т.д., которые включают в себя разделы и файлы виртуального диска или образа диска.

Откройте файл виртуального диска (или образ диска) «Диск» > «Открыть файл виртуального диска». Выберите файл виртуального диска (или образ диска) и PartitionGuru загрузит его. Вы должны быть осведомлены, что виртуальный диск можно только открыть в PartitionGuru, он не загружается в операционной системе, его разделы не видны в "Мой компьютер", поэтому не может быть назначена буква дисков.

После открытия виртуального диска вы можете работать как с обычным диском. Все функции, за исключением назначение буквы диска, применимы к нему: создание, удаление и форматирование раздела, копирование файлов, восстановление файлов, восстановление разделов, копирование разделов, копирование диска и т.д.

Файл виртуального диска будет отображаться следующим образом:


5. Ñîçäàòü îáðàç äèñêà èëè ôàéë îáðàçà ðàçäåëà

5. Создать образ диска или файл образа раздела

PartitionGuru поддерживает диски и разделы из несжатых файлов образа. Кроме сжатого файла PartitionGuru может открыть любой файл образа: ".img", ".ima", "vfd" и ".flp", также создавать свои файлы. Этапы создания файлов образа:

Нажмите «Диск «>» Создать новый файл виртуального диска» > «Создать файл образа» ".img". PartitionGuru покажет диалоговое окно:

Задайте путь, имя файла и размер. Можно выбрать размер из пяти вариантов, размеры взяты исходя из стандартного размера дискет: 360K, 720K, 1. 2 m, 1.44 M и 2.88M, также можно указать размер самостоятельно, затем вы можете выбрать тип файла образа, «Образ диска» или «Образ раздела». Образ диска это также, как реальный диск, который может быть перераспределен, образ раздела похож на образ дискеты, который может быть отформатирован но не перераспределенн.

По умолчанию PartitionGuru создаст образ загрузочной DOS-системы. Таким образом, загрузочный файл образа может быть использован для загрузки виртуальной машины или чтобы сделать загрузочный компакт-диск. В связи с защитой авторских прав программного обеспечения PartitionGuru принимает FreeDOS, которая является небольшой, свободно распространяемой и совместимой с MS-DOS. Если вам нужно использовать систему MS-DOS, можно просто заменить файлы в папке «dos» в каталоге PartitionGuru на системные файлы MS-DOS.

Нажмите кнопку "OK" для создания образа.

PartitionGuru после завешения откроет файл образа. Можно добавлять другие файлы в образ с помощью функции копирования файлов.


Îïåðàöèè ñ ôàéëàìè

Операции с файлами

PartitionGuru поддерживает следующие операции с файлами:

1. Обзор файлов

2. Копирование файлов из раздела

3. Запись файлов в раздел

4. Безвозвратное удаление файлов

5. Создать папку

О восстановлении удаленных или потерянных файлов, обратитесь в "Восстановить удаленные или потерянные файлы".


1. Ïðîñìîòð ôàéëîâ

1. Просмотр файлов

В PartitionGuru можно просмотреть все файлы раздела, в том числе те, просмотр которых ограничивает операционная система. Как правило операционная система скрывает много файлов, с целью защиты важных файлов и поддержки стабильной работы системы. При отображении файлов PartitionGuru анализирует тип файловой системы и чтение записи в секторах диска. Поэтому PartitionGuru может показать все файлы раздела.

PartitionGuru отображает файлы так же, как в проводнике Windows. Отображается иерархическая структура папки в левой части и подробный список файлов справа. По умолчанию правая часть показывает параметры раздела. Если вы выберите папку слева, то правая часть переключится на список файлов. Так же вы можете переключать нажав кнопку "Файлы" на правой панели:

Свойства файла, показанные PartitionGuru включает: значок, имя, размер, тип файла, атрибуты показанные буквами, краткие имена файлов, время изменения и время создания. Файлы с атрибутами, скрытый, системный, сжатый и зашифрованный - окрашены в разные цвета, чтобы отличить друг от друга. Расшифровка по буквам в "Атрибуты файлов" показана на рисунке ниже:

"D", "X" атрибуты описаны в "Восстановление удалённых файлов".

Вы можете сделать некоторые Операции с файлами в меню "Файл" или в всплывающем меню, щелкнув на правую кнопку мыши:


2. Êîïèðîâàíèå ôàéëîâ èç ðàçäåëà

2. Копирование файлов из раздела

PartitionGuru может копировать файлы из раздела в назначенную папку.

Выберите файлы, которые вы хотите скопировать в списке файлов, щелкните правой кнопкой мыши и в всплывающем меню выберите пункт «Копировать в" или выбрав пункт меню «Файл» > «Копировать в».

Нажмите кнопку "Копировать в" и выберите папку. PartitionGuru скопирует выбранные файлы в указанную папку.

Нажмите кнопку «Подробнее», чтобы увидеть подробный результат копирования файлов.


3. Çàïèñü ôàéëîâ â ðàçäåë

3. Запись файлов в раздел

PartitionGuru может копировать файлы на скрытые разделы и разделы не имеющие букву диска, поддерживает файловые системы NTFS/FAT32/FAT16/FAT12. PartitionGuru полностью независим от операционной системы. Операция будет совершена обязательно и может не соответствовать требованиям операционной системы или программного обеспечения, таким образом, эта операция является своего рода рискованной. Пожалуйста, будьте осторожны при проведении этой операции.

Чтобы облегчить работу PartitionGuru предоставляет несколько способов копирования файлов в раздел. Перед копированием выберите нужную папку целевого раздела.

1.Из меню.

После выбора целевого раздела и папки, щелкните правой кнопкой мыши на панели со списком файлов и в всплывающем меню выберите пункт «Копировать файлы в текущий раздел»:

PartitionGuru покажет диалоговое окно "Выбор файла для копирования», вы можете выбрать файл (или несколько), PartitionGuru скопирует файлы в целевую папку. Эта функция не может скопировать папку. Чтобы скопировать папку и файлы, обратитесь к следующему способу.

2.Перетаскивание мышью.

После выбора целевого раздела и папки, в проводнике Windows выберите файлы (или папки). Перетащите файлы (или папки) левой кнопкой мыши в целевую папку "Разделы и дерево папок" или "Список файлов" . В PartitionGuru появится следующее сообщение:

Нажмите кнопку «Да», чтобы запустить процесс копирования.

3.С помощью сочетания клавиш.

Выберите файлы (или папки) в проводнике Windows, нажмите клавиши "Ctrl+C", далее вернуться в PartitionGuru, выберите целевой раздел и папку, нажмите клавиши "Ctrl+V". PartitionGuru покажет то же диалоговое окно, как указано выше, нажмите кнопку "Да" и начнётся копирование файлов.


4. Áåçâîçâðàòíîå óäàëåíèå ôàéëîâ

4. Безвозвратное удаление файлов

В PartitionGuru имеется функция "Безвозвратное удаление файлов», которая минует драйвер файловой системы и удаляет напрямую запись файла на диске. Удаляет файлы из разделов, за исключением системного раздела. Эта функция удаляет файлы, которые нельзя удалить обычным способом.

Выберите файл в списке файлов , который вы хотите удалить . Щелкните правой кнопкой мыши на файл и в всплывающем меню выберите «Безвозвратное удаление файлов», как показано ниже, или выбрав пункт меню «Файл» > «Безвозвратное удаление файлов».

PartitionGuru блокирует раздел в котором находится файл. Чтобы предотвратить потерю данных, выйдите из всех программ и закройте все файлы этого раздела. После удаления файла раздел можно использовать как обычно.


5. Ñîçäàòü ïàïêó

5. Создать папку

PartitionGuru может создавать папки в разделах, он создает папки на диске напрямую.

Выберите путь, где вы хотите создать папку в списке файлов, щелкните правой кнопкой мыши и в всплывающее меню или в пункте меню «Файл «>»нажмите Создать папку».

Выбрав пункт «Создать папку», появится диалоговое окно «Создать папку», введите имя папки и нажмите кнопку «ОК», как показано ниже:

PartitionGuru блокирует раздел, где будет создана новая папка. Для предотвращения потери данных, выйдите из всех программ и закройте все файлы раздела, прежде чем создать новую папку. После того, как папка будет создана, раздел можно использовать как обычно.


Äðóãèå îïåðàöèè

Другие операции

PartitionGuru поддерживает следующие операции:

1. Перезагрузка и запуск DOS-версии PartitionGuru


Ïåðåçàãðóçêà è çàïóñê DOS âåðñèè

Перезагрузка и запуск DOS версии

 Top Previous

Некоторые функции недоступны в системе Windows, но они будут доступны в системе DOS. В PartitionGuru есть функция загрузки в DOS-версию, без использования boot CD, загрузочного USB флэш-диска или установленной DOS на жестком диске. PartitionGuru отображает разделы диска в DOS-версии так же, как и в Windows. После перезагрузки компьютер загрузится с текущей системой Windows.

Для выполнения этой функции нажмите «Файл» > «Перезагрузить в DOS версию»:

Далее PartitionGuru покажет сообщение:

Перед нажатием кнопки «ОК», сохраните данные программного обеспечения, закройте все приложения и программы. Нажмите кнопку «ОК» и PartitionGuru загрузится в DOS-версию.

После завершения операции в DOS-версии, можно выключить или перезагрузить компьютер. Компьютер будет перезагружен автоматически в систему Windows.